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Foreword 

This user's manual contains useful information about the precautions, functions, 
and operating procedures of the X-Wirepuller program that is downloadable from 
http://www.yokogawa.com/tm/tm/softdownload.htm. To ensure correct use, 
please read this manual thoroughly during operation. 
After reading the manual, keep it in a convenient location for quick reference 
whenever a question arises during operation. 
For information about the handling precautions, functions, and operating 
procedures of the DL series digital oscilloscopes, and the handling and operating 
procedures of Windows, see the manuals that accompany the particular instrument 
you are using. 
 

Notes 
• The contents of this manual are subject to change without prior notice as a result 
of continuing improvements to the instrument's performance and functions. The 
figures given in this manual may differ from the actual screen. 
• Every effort has been made in the preparation of this manual to ensure the 
accuracy of its contents. However, should you have any questions or find any 
errors, please contact your nearest YOKOGAWA dealer. 
 

Trademarks 
• MS-DOS, Windows, and Windows NT are either registered trademarks or 
trademarks of Microsoft Corporation in the United States and/or other countries. 
• Adobe and Acrobat are trademarks of Adobe Systems incorporated. 
• For purposes of this manual, the TM and ®symbols do not accompany their 
respective trademark names or registered trademark names. 
• Other company and product names are trademarks or registered trademarks of 
their respective companies. 
 

Revisions 
1st Edition:  September 2005 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
All Rights Reserved, Copyright © 2005 Yokogawa Electric Corporation 
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Product Overview 
 
 
Functions 

 
Controlling the DL Series Digital Oscilloscopes 
Enables the DL9000 series digital oscilloscopes to be controlled from your PC via 
the NIC, USB, or GP-IB interface.  When the software program starts, the front 
panel image of the connected DL (control panel) appears on the monitor of your PC. 
Using a mouse, you can control the DL from your PC through operations that are 
similar to those for the front panel keys of the instrument. 

 
Saving Screen Images 
Saves the screen image data displayed on your PC in BMP format. 
 
Selecting the Control Window Size 
You can select the size of the control window that is displayed on your PC from the 
choices below. When the display resolution of the PC is small, the control window 
can be displayed reduced in size. 
• Larger: Displays the screen image of the DL using the same number of pixels as

 the number of pixels of the entire screen of the connected instrument. 
• Standard: Displays the screen image of the DL using 65% of the number of pixels 
of the entire screen of the connected instrument. 
• Smaller: Displays the screen image of the DL using 50% of the number of pixels 
of the entire screen of the connected instrument. 
• Full screen: Displays the screen image of the DL with a full-screen mode. 
 
Selecting the Display Update Rate 
You can select the display update rate of the DL screen image from the following. 
However, the actual display update rate may be slower than the specified update 
rate depending on the network transmission system or the amount of 
communication load. 
“300milliseconds to 10 seconds”  
 
Updating the Screen 
The screen image of the DL can be forcibly updated. This is done when the display 
update rate is set to a low value or when the display update is paused. 

 
Pausing Display Update Operation 
Pauses the display update operation. 
Pausing the display update operation improves the response of the software 
program such as when turning ON/OFF numerous items at once or when entering 
values from a keyboard. 
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Control Screen 
 
For DL9000 Series Digital Oscilloscopes 
 

 
 
 

Break up connection to DL 
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PC System Requirements 

 
PC 
PC capable of running Windows 2000 and Windows XP with at least a PentiumⅢ 
1 GHz processor and at least 256 MB of memory. 
In addition, a USB driver for the connected DL is required. For details on the USB 
drivers, see the user’s manual for the relevant DL. 
 
CRT, printer, and mouse 
Display: XGA or more 
Color: 65536 colors or more 
Must support Windows2000 and Windows XP. 
 
GP-IB Board 
When using the GP-IB interface, GP-IB board by National Instruments or a 
PCMCIA card is required. 

 
DL Series Required for Operation 
DL9000 Series:  Version 1.60 or later 
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Notes on Using the Software 
 

Exemption from Responsibility 
Yokogawa Electric Corporation shall not be held responsible by any party for any 
losses or damage, direct or indirect, caused by the use or any unpredictable defect 
of the product. 
 
Precautions Concerning the Use of the Software 
• Do not perform operations directly on the DL series digital oscilloscopes while 
using this software program. Doing so can lead to erroneous operation. 
• If the standby mode provided on your PC is activated, the operation of the 
software may not be able to continue. 
When using the software, turn OFF the standby mode. 
• If you run the software using a NIC interface, the line load is 1 Mbytes/s maximum. 
Consult your network administrator on using the NIC interface. 
• If a connection error occurs when connecting to a DL digital oscilloscope, power 
cycle the DL. 
• Do not set the network or communication parameters of the DL series using this 
software program. The connection may be disconnected. 
• Do not execute self-tests using this software program. 
• Simultaneous connections from multiple PCs to a single DL series digital 
oscilloscope are not allowed. 
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1.1 Controlling the DL Series 
 

Setting the Interface 
 
Set the interface to be used from the front panel of the DL. 
For DL9000: SYSTEM > Remote Control > Device 

 
• Example (DL9140) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  SYSTEM MENU  for USB   for GP-IB   for Network 
 
 

＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿ 
Note: 

• For details on how to operate the DL, see the user's manual for the DL. 
＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿ 
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1.2 Controlling the DL Series 
 
  Click the file XWirepuller.exe to display the following window. 
 

 
 

 
 
 
 
 
 
 

Create Connection to the DL Instrument 
Click File > Connect menu or  Icon, the connect dialog will then open. The 
predefined connection configurations are listed in it as follows. 
 

   
 
 

Add New Connection Configuration 
The connection configuration list is empty at first start. To add new connection 
configuration to the DL, click the Add button. A new device configuration dialog will 
then open in which users can select the variable communication port and setup the 
corresponding parameters. 
Set the interface to be used from the menu of the DL. 

For DL9000:  SYSTEM > Remote Control 

＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿ 
Note: 
• Before creating communication with the DL, make sure that the cable between PC  
and DL has been correctly wired.  For the hardware connection between PC  
and DL, please refer to the communication operation guide of your specific instrument.
＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿ 
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GPIB  

Address:  The unique ID of a GPIB device, ranges from 
0~30 

Ethernet 
IP Address:   The IP address or host name of the instrument 
Username:  The login username for the Remote Control 

assigned by the instrument 
Password:   The password for the username 

 
   USB-TMC 

Serial:  The serial No. of the instrument 
 

 
 

Click the OK button to add new connection configuration into the configuration list. 
The program will try to check the correctness of the configuration, if succeeded, it 
will display the instrument model name, and otherwise it will return an error 
message and display “unknown” as model name. 

 
Remove Connection Configuration 
Click the Remove button to remove a selected connection configuration from the 
configuration list. 

 
Change Connection Configuration’s Parameters 
Click the Property button to change a selected connection configuration’s 
parameters, a configuration property setting dialog will then open which looks same 
as the new instrument dialog. Change the connection configuration’s parameters 
and click the OK button to save changes. 
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1.3 Creating / Breaking up Connection 
 

Create Connection to the DL Instrument 
Select a defined connection configuration in the configuration list and click the 
Connect button to connect to the DL. (Double click on defined configuration in the 
list, also can create connection.) The program then will try to initialize the 
communication to the DL with selected configuration. If succeeded, the control 
window for the instrument will be displayed else, an error message will be 
displayed. 
 

  
 
 

 
Break up Connection 
Click File > Disconnect menu or  icon to break up current connection to the 
DL .



 Chapter 2 Functions 
 

B9852UL-01E 12

2. Functions 
 
Operation panel 
Click View > Panel menu to display or hide the operation panel. 
 

 
 

 
Control Window Size 
Click View > Zoom menu to set the control window size. 

• Larger: Displays the screen image of the DL using the same number of 
pixels as the number of pixels of the entire screen of the connected 
instrument. 
• Standard: Displays the screen image of the DL using 65% of the number 
of pixels of the entire screen of the connected instrument. 
• Smaller: Displays the screen image of the DL using 50% of the number 
of pixels of the entire screen of the connected instrument. 

 

 
 
 
 
Full screen display 
Click View > Full Screen menu or  icon to display with a full-screen mode. 
The full-screen mode ends if the “ESC” key of the personal computer is pushed, 
and it returns to a usual display.  
The full-screen mode or display of the operation panel can be ended by pushing 
mouse's right button while pushing the “CTRL” key to the personal computer. 
 
 
 
 
Updating the Screen 
Click View > Update menu or  icon to update the screen image. 
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Pausing Display Update Operation 
Click View > Pause menu or  icon to pause the display update operation. 
 
 
 
 
 
Display update Interval 
Click View > Options menu, the option dialog will open as follows. 
The setting ranges of the interval are from 300 milliseconds to 10 seconds.   
 

 
 
 
 
Saving Screen Images 
Click Tools > Image menu to save the screen image data displayed on your PC in 
BMP format. 
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Two or more DL 
 

Click Window > Cascade menu, all open windows are cascaded. 
Moreover, the list of connected DL is displayed in the menu, and the window can be 
displayed on the foremost side by clicking it. 
 

 
 
 
 
. 
 
 
 
 
 
 
Viewing version information 
Click the Help menu, the version of XWirepuller you are currently using is 
displayed. 
 
 

＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿ 
Note: 
• When two or more DL is controlled, the connection might be cut by the situation
connected DL and line. Please use it by the number that can be connected with stab
＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿＿ 
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3 Control Window Operation 
 

Using the Mouse 
The displayed icon and the mouse operation vary depending on where the mouse 
pointer is located on the control window. The following table shows the mouse 
operation for each icon and the operation of the DL series digital oscilloscopes. 
 
 
Mouse Pointer 
Position 

Displayed Icon 
and Mouse 
Operation 

Operation 
 

Operation key 
  

Click operation 

 
 
Same as pressing the operation key 

Screen  

 
Click operation 
Wheel operation 

 
 
Same as the mouse operation of the DL series 
Same as the mouse operation of the DL series 

Area to the left or 
right  
of the jog shuttle 
 

 
Click operation 
Wheel operation 

 
 
Same as turning the jog shuttle to the left or right 
Same as turning the jog shuttle 

Area to the left, 
right or center of 
the VERTICAL 
SCALE knob 

 
Click operation 
Wheel operation 

 
Click operation 

 
 
Same as turning the SCALE knob to the left or right 
Same as turning the SCALE knob  
 
 
Same as pressing the SCALE knob 

Area to the left, 
right or center of 
the VERTICAL 
POSITION knob 

 
Click operation 
Wheel operation 

 
Click operation 

 
 
Same as turning the POSITION knob to the left or right 
Same as turning the POSITION knob  
 
 
Same as pressing the POSITION knob 

Area to the left or 
right  
of the T/DIV knob 
 

 
Click operation 
Wheel operation 

 
 
Same as turning the T/DIV knob to the left or right 
Same as turning the T/DIV knob 

Area to the left or 
right  
of the MAG knob  

Click operation 
Wheel operation 

 
 
Same as turning the MAG knob to the left or right 
Same as turning the MAG knob 
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Example of Mouse Operation 
 
1. Operation Key Operation 
Click to select Sine. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. Jog Shuttle Operation 
Click or operate the wheel to set. 
 
 
 
 
 
 
3. VERTICAL POSITION Knob Operation 
Push the knob to change FINE mode. 
 
 
 
 
 
 
 
 
 
 
 
4. T/DIV Knob Operation 
Turn the wheel to change the T/div setting. 
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4 Exiting the Application 
 

Exiting the Application  
Click File > Exit menu or  icon to exit the application. 
 

 


